06:31 patrickarlt joined #geoloqi
07:58 patrickarlt joined #geoloqi
09:58 hagia joined #geoloqi
10:49 patrickarlt joined #geoloqi
11:18 dr2391 joined #geoloqi
11:18 <dr2391> Hi, I was talking to aaron last week about a problem with push notifications and then was emailing Manuel Lopez but haven't received a response in about 6 days now. I was wondering if Aaron or anyone has any info on this
11:19 <dr2391> i have successfully got push notifications working on parse.com so it is not a problem with my certs or my setup
12:55 hagia joined #geoloqi
12:56 <manny__> dr2391: hello
12:56 <manny__> your certs are definitely not the problem then
12:57 <manny__> and we confirmed that they were put into the correct fields, right?
12:59 <manny__> I'll dedicate the rest of today to troubleshooting why your device isn't receiving push notifications
12:59 <manny__> what device are you using?
13:32 popugaeva joined #geoloqi
13:33 <manny__> dr2391: let me know when you have a second. I have a couple of questions.
13:39 <dr2391> sorry manny i am here now
13:40 <dr2391> and yes my certs are in the correct boxes
13:41 <dr2391> and I'm using an iPhone 5 with 7.1 b2
13:41 <dr2391> although the problem was happening on 7.0.4 too
13:41 madatov joined #geoloqi
13:47 <manny__> dr2391: myself and one of our developers here have been looking at our logs and can't reproduce your results
13:48 <manny__> when creating your certs, did you go through these steps?: https://developers.arcgis.com/en/geotrigger-service/guide/ios-push-notifications/
13:49 <dr2391> yeah thats the guide i followed
13:53 <manny__> dr2391: one second, please
13:54 <dr2391> alright no problem
13:59 <manny__> dr2391: could you try to send a notification again?
13:59 <manny__> client ID is still xQD0v2GR9k7aHhur?
14:00 <dr2391> correct
14:00 davy_ joined #geoloqi
14:00 <manny__> perfect
14:01 <manny__> let me know when youve tested again
14:01 <dr2391> just did
14:01 <dr2391> nothing still
14:01 <dr2391> device/notify success: { devices = { WgjR0lKitnPLkE86 = queued
14:01 <dr2391> }
14:01 <dr2391> }
14:07 <manny__> we are seeing both your certs on the error logs
14:07 <manny__> trying to locate why the certs arent being retrieved from arcgis
14:15 <manny__> dr2391: it looks like we found a bug
14:15 <manny__> could you paste the sandbox cert into both cert fields and test that way, please?
14:16 <manny__> let me know what you get back
14:18 <dr2391> sure
14:21 <dr2391> still got success but no notification
14:23 davy_ joined #geoloqi
14:24 <manny__> dr2391: thanks
14:28 <manny__> dr2391: looking into it now. I'll try to delete the cache and have you try again in a bit to see if anything changes
14:28 <manny__> okay, cleared. please try again
14:32 <dr2391> still nothing. would having push setup with the parse.com api at the same time be causing problems?
14:33 <dr2391> just to be clear, i was having the problem before setting up with parse
14:34 <manny__> i don't think so
14:34 <dr2391> alright just making sure
14:35 <manny__> I think the problem is that we are cacheing an invalid apns key
14:35 <manny__> and we are using that instead of the valid one you are sendings
14:36 <manny__> okay, please send another test
14:39 <dr2391> still nothing
14:39 <dr2391> oh wait
14:39 <dr2391> just got it
14:40 <manny__> hooray!
14:40 <dr2391> yup tried it again, they're working!
14:40 <dr2391> thanks
14:40 <manny__> awesome
14:41 <manny__> sorry for how long this took, but you helped uncover 2 different issues with our beta product
14:41 <manny__> I'll follow up wit the team here and get those solved
14:41 <dr2391> no problem
14:41 <dr2391> happy i could help
14:42 <manny__> please let me know if you run into anything else
14:44 <dr2391> one other thing i noticed that with the triggerBuilder is that you cannot set the "times" param
14:45 <dr2391> not really a big problem, I'm just using [[AGSGTApiClient sharedClient]postPath:@"trigger/create"... instead
14:46 <manny__> thinking more about this, you are going to run into problems when you go into production mode
14:47 <manny__> we implemented a very hacky solution by using sandbox certs in both cert fields
14:47 <manny__> not viable for the long term
14:47 <manny__> this is definitely a big problem for us
14:48 <dr2391> do you have any kind of time estimate for a fix?
14:51 <manny__> unfortunately, not right now. writing the escalation email now
14:51 <manny__> what is your timeline?
14:53 <dr2391> well i am getting real close to beta testing which would require the production certs
14:54 <dr2391> was hoping within a week
14:54 <dr2391> i can live without the sandbox certs if it means i can have the production certs working
15:05 <manny__> after this email get sent out, I can have a better timeframe for you
15:11 <dr2391> sounds good
15:49 davy__ joined #geoloqi
15:53 davy_ joined #geoloqi
16:04 patrickarlt joined #geoloqi
16:26 davy_ joined #geoloqi
16:29 manny___ joined #geoloqi
17:08 patricka_ joined #geoloqi
17:18 patrickarlt joined #geoloqi
20:27 davy_ joined #geoloqi
23:50 plambre joined #geoloqi