2013-07-05

05:56 reidab joined #geoloqi
05:56 aaronpk joined #geoloqi
05:56 plambwk-- joined #geoloqi
05:56 NESTFaz joined #geoloqi
05:56 josh_ joined #geoloqi
06:19 NESTFaz joined #geoloqi
06:20 plambwk-- joined #geoloqi
07:03 webchat246 joined #geoloqi
07:03 <webchat246> anone on here familar with js and streaming?
07:27 <webchat246> Good morning. Is this still active?
07:28 josh- joined #geoloqi
07:39 countrdd joined #geoloqi
07:40 <countrdd> Could uses some help on streaming apis
07:40 <countrdd> anyone around?
09:28 ngoldman joined #geoloqi
09:43 patrickarlt joined #geoloqi
10:11 patricka_ joined #geoloqi
10:40 ngoldman joined #geoloqi
11:09 courtf joined #geoloqi
12:13 courtf joined #geoloqi
12:39 countrdd joined #geoloqi
12:39 <countrdd> @geoloqi
12:40 <countrdd> Anyone worked with the streaming server?
12:54 n8ji joined #geoloqi
13:17 CourtFowler joined #geoloqi
13:25 <countrdd> good afternoon
13:25 <countrdd> Can anyone help me with the streaming socket with js?
13:26 <patricka_> countrdd: what are you having trouble with?
13:27 <countrdd> Just a couple questions. Once a user subscribes/joins a group does it automatically update their location on the streaming server?
13:27 <countrdd> I am using the titanium sdk.
13:28 <countrdd> My group is 2JALdmxZU and is public and open
13:28 <patricka_> yes you dont get any information about their previous location over the socket but new location should be coming over the socket for a group as soon as the user joins
13:28 <countrdd> I am using the example on the docs site. and put group and the token 2JALdmxZU
13:29 <patricka_> are you not seeing locations come over?
13:29 <countrdd> in the js.
13:29 <countrdd> no.
13:29 <countrdd> http://reeldealnetwork.com/ddctest.hmtl is the link/ie. code that was expexting to see it at
13:30 <patricka_> that page 404's for me
13:31 <countrdd> hmm
13:32 <countrdd> that is weird.
13:32 <countrdd> reeldealnetwork.com does that work?
13:33 <countrdd> crap
13:33 <Loqi> lolz
13:33 <countrdd> reel is spelled like fishing reel...
13:33 <countrdd> but it is coming up for me fine...
13:34 <countrdd> the link above had html wrong...my fingers are not working well today...
13:37 <countrdd> any ideas?
13:38 <patricka_> ok try replaceing your auth with 'trip', 'TQ4ew3Z'
13:39 <patricka_> if you see stuff in the logs then you can connect with the socket ok
13:40 <countrdd> yeah. I did that first....
13:40 <countrdd> and it worked.
13:41 <countrdd> is trip a special thing?
13:41 <countrdd> and btw. thanks for the help!
13:43 <patricka_> a trip is like a limited time token generally used for sharing location for a limted period of time
13:43 <patricka_> ok so that works
13:43 <patricka_> how many members in your group?
13:43 <countrdd> just one right now. because of testing.
13:44 <countrdd> and that person is on an emulator..ios.
13:44 <patricka_> ah ok
13:44 <countrdd> is that a problem?
13:44 <patricka_> might not be titanium api is depricated though
13:45 <patricka_> ok get the users token out of the titanium api and paste it into the api console http://developers.geoloqi.com/api/console
13:45 <patricka_> and try to get location history
13:46 <countrdd> 121f73-1c3882d4577c4f68be99b6e093ffb3ce7082853a
13:46 <countrdd> trying now.
13:46 <countrdd> it showed them ok
13:46 <patricka_> ok so there is history
13:46 <countrdd> yeah
13:47 <countrdd> (I know titanium is deprecated...I was the one that asked you to open source it. I got some programmers that are looking at it as well as myself)
13:47 <patricka_> well if there are items in the history that means that titanium sdk still talks to api ok
13:48 <countrdd> yea just not seeing it on the socket streaming side.
13:48 <patricka_> let me try something since i have your access token
13:49 <countrdd> ok. you can have what ever tokens you want!
13:49 <countrdd> thank I really apprecaite it.
13:51 <countrdd> brb
13:51 <patricka_> can you pm me your client id?
13:51 <countrdd> yep
13:52 <countrdd> is client id same as api key?
13:57 <patricka_> nevermind i dont need then still testing some stuff
13:57 <countrdd> K.
14:01 <patricka_> ok so i think tracking via trips is working but users and groups is not. Here is what i was doing.
14:03 <patricka_> i was using https://github.com/geoloqi/location-simulator to push data into the user who was in your group and listening for it with both user auth and group auth and nothing. But since the "trip" that i gave you above still seems to work ok streaming is working. also the iss feed is not working http://geoloqi.com/iss which is a user with public location turned on.
14:03 <patricka_> aaronpk: ping
14:03 <patricka_> countrdd: whats your email?
14:03 <countrdd> countrdd@leillc.net
14:04 <patricka_> ok im going to send an email to aaron and ask him to take a look at this.
14:04 <countrdd> thanks I apprecaite it.
14:05 <patricka_> in the meantime try using link/create to get a token to use with "trip" you can just make one that doesnt expire http://developers.geoloqi.com/api/link/create
14:08 <countrdd> is the data that is sent back the same for either?
14:10 <patricka_> they all give you the same data over the socket just different ways to get it
14:10 <countrdd> ok. Thanks alot.
14:38 countrdd_ joined #geoloqi
14:41 countrdd joined #geoloqi
14:53 ngoldman joined #geoloqi
16:13 ngoldman joined #geoloqi
21:49 patrickarlt joined #geoloqi
22:01 ngoldman joined #geoloqi