2013-03-15

07:05 patrickarlt joined #geoloqi
07:19 <Loqi> https://twitter.com/LocaleHQ :: What could your app do if it knew where it was? Check out @geoloqi http://geoloqi.com/
07:56 patrickarlt joined #geoloqi
07:58 patricka_ joined #geoloqi
08:51 caseorganic joined #geoloqi
09:01 caseorga_ joined #geoloqi
09:35 plamb- joined #geoloqi
10:03 caseorganic joined #geoloqi
10:06 caseorga_ joined #geoloqi
10:30 jaxmeier joined #geoloqi
10:35 <jaxmeier> Any support folks online?
10:41 <patricka_> hang on a sec what is the question about?
10:42 <jaxmeier> Hi Patrick. I am suddenly getting 403 errors on place create. Worked fine last week.
10:42 <jaxmeier> I posted details in support but I am on an extreme time crunch
10:43 aaronpk joined #geoloqi
10:43 <patricka_> aaronpk: can you take this? jaxmeier says Hi Patrick. I am suddenly getting 403 errors on place create. Worked fine last week.
10:43 <jaxmeier> I can see the init calls and layer subscription succeeds
10:44 <aaronpk> hi there
10:44 <jaxmeier> As does login
10:44 <jaxmeier> Hi aaron
10:46 <jaxmeier> Not sure where you stepped in but I am suddenly getting 403 errors on place/create with no code changes. Init anon login and layer subscribe succeed.
10:46 <jaxmeier> Worked fine as of 3/9
10:46 <aaronpk> can you share an ID of the layer you're trying to create teh place on?
10:46 <jaxmeier> Sure. Just one sec while I look it up.
10:47 <jaxmeier> 3w6d
10:48 <aaronpk> ok and is this a new layer created by the new user?
10:50 <jaxmeier> No. I hard coded the layer ID.
10:50 <aaronpk> hmm. well only the user who created the layer can add places to it
10:51 <jaxmeier> And their in lies the answer. So if I create the layer through the website, can any user add a place and create a trigger?
10:51 <aaronpk> no
10:52 <aaronpk> in order to do that you'd need to set up a server that has your application access token, and the devices would make a request to your server and your server could add the place
10:52 <jaxmeier> Yikes.
10:53 <aaronpk> yea, this is a known limitation of the current permissions model. the new version of the API will be able to support this use case.
10:53 <jaxmeier> So anyone can subscribe, but there is no generic public layer available without an external server. How soon?
10:54 <aaronpk> anyone can subscribe to public layers, but it is not possible to have anybody write to layers
10:54 <jaxmeier> We are presenting to the PNC Bank Chairman on Monday. Guess ill be whipping up a server right quick lol.
10:54 <aaronpk> it shouldn't take much, what language do you do server-side work in?
10:55 <jaxmeier> Looks like a few all nighters. C# and SQL. Totally doable. Server side is my bread and butter.
10:55 <aaronpk> ah ok. I haven't done C# in many many years so I can't be much help there
10:56 <aaronpk> the short version is you need to make an API method like "place/create" on your server, pass through all the parameters from the request, and hard-code the layer ID and application access token then pass that to the geoloqi API
10:56 <jaxmeier> No worries. Service stack or even a basic mvc site will do. Just a simple pass through to geoloqi.
10:56 <Loqi> THROUGH ALL THE PARAMETERS http://loqi.me/6kK
10:57 <aaronpk> cool
10:57 <jaxmeier> Should be easy enough. I already have everything in the phone code to pass through.
10:58 <jaxmeier> Many thanks for the quick clarification. Should be easier than the push stuff. Lol
10:58 <aaronpk> great. heh, push notifications are always a pain
10:58 <jaxmeier> Got to get back to the real job now. Thanks for jumping in.
10:58 <aaronpk> you're welcome!
10:59 <jaxmeier> Take care aaron.
11:02 patrickarlt joined #geoloqi
12:06 FrankP joined #geoloqi
12:23 se7h joined #geoloqi
12:47 <Loqi> https://twitter.com/ryepdx :: @geoloqi Hey guys, it's a bit past January 15th. Maybe you should update your pricing page...
13:13 patrickarlt joined #geoloqi
15:14 patrickarlt joined #geoloqi
15:30 kyledrake joined #geoloqi
17:23 patrickarlt joined #geoloqi
17:42 patrickarlt joined #geoloqi
19:08 jaz joined #geoloqi
19:09 <Guest38159> hi guys, i have a problem with create place using api
19:10 <aaronpk> hi there
19:10 <aaronpk> what's the issue?
19:10 <Guest38159> i have attached layer_id in the parameter of the create place api, but the return result has an empty layer_id always
19:11 <Guest38159> is it im missing something ?
19:11 <Guest38159> the layer is private in my application
19:12 <aaronpk> let me check, hold on
19:12 <Guest38159> ok
19:13 <Guest38159> this is the url of the layer https://a.geoloqi.com/layer/description/56nu
19:13 <Guest38159> but i cant see anything in my chrome browser
19:13 <aaronpk> probably because it's private
19:13 <aaronpk> that's fine
19:14 <Guest38159> so i need to make it public ?
19:14 <aaronpk> ok i just checked, and you won't get the layer_id back in the response
19:14 <aaronpk> that's normal
19:15 <Guest38159> oh, ic
19:15 <aaronpk> you should be able to see the place if you do place/list?layer_id=56nu
19:15 <Loqi> fo sho
19:16 <Guest38159> ok, let me try it now
19:28 <Guest38159> thanks aaronpk :)
19:29 <aaronpk> you're welcome!
20:21 patrickarlt joined #geoloqi
20:40 jaz_m joined #geoloqi
20:43 <jaz_m> hi guys, is there any different using application_access_token or user_access_token to create layer / place ?
20:43 <jaz_m> because i cant see the layer or place that i create using user access token when im listing those record using application access token
20:53 plamb joined #geoloqi
20:57 kyledrake joined #geoloqi
21:09 kyledrake joined #geoloqi
22:11 patrickarlt joined #geoloqi
23:18 <jaz_m> how if i want to list all the places no matter what is the layer_id ?
23:18 <jaz_m> the api place/list is just retrieve the places with default layer_id
23:18 <Loqi> the layer is now marked as public
23:19 <jaz_m> yes, its public now
23:22 <jaz_m> so is there any way ?