2012-07-18

04:46 <Loqi> http://twitter.com/AyandaMo :: What about Geoloqi? It's free RT @TheStreet: Apps to Help You Remember Mundane Tasks: Android Edition - http://t.co/qdi9my5I
06:24 <Loqi> http://twitter.com/useVICTOR :: Smartphone Battery Dead Again? Geoloqi Locates a Possible Solution | Underwire | http://t.co/nvrjK9HM http://t.co/HuhM8kpA
07:26 <Loqi> http://twitter.com/Thomas_Wendt :: @grokstar Geoloqi, OpenPath, and ReplayMyDay...and Highlight to limited extent. So I guess 3.5 is more accurate.
07:28 patrickarlt joined #geoloqi
07:30 <Loqi> http://twitter.com/Thomas_Wendt :: @grokstar Geoloqi has built a nice framework, from what I can tell. Now it's time for people like us to build on it.
08:16 patrickarlt joined #geoloqi
09:28 <Loqi> http://twitter.com/dhgwilliam :: @geoloqi Aww shucks thanks for coming! http://t.co/cuifUnMj
09:40 kenichi joined #geoloqi
10:12 kyledrake joined #geoloqi
11:22 <Loqi> http://twitter.com/appcelerator :: Learn How to Use Geoloqi and Many More Marketplace Modules On Your Titanium App #AppCWebinar http://t.co/sDyNiL3m
11:24 <Loqi> http://twitter.com/TomCiopp :: @kenichi_pdx How do I get involved in the geoloqi heroku alpha?
11:27 starbuckt joined #geoloqi
11:32 <Loqi> http://twitter.com/kenichi_pdx :: just send me the email address you use on @heroku :) RT @TomCiopp: @kenichi_pdx How do I get involved in the @geoloqi @heroku alpha?
12:05 FrankP_ joined #geoloqi
12:25 kenichi_ joined #geoloqi
12:25 patricka_ joined #geoloqi
13:04 <Loqi> http://twitter.com/fredskronk :: Is @geoloqi down? Dont get any data at all from the API. @geoloqi_status
13:08 <Loqi> http://twitter.com/patrickarlt :: @fredskronk @geoloqi @geoloqi_status We had a small blip earlier today. But I've been having no trouble for the last few hours.
13:16 Fredskronk joined #geoloqi
13:17 <Fredskronk> Hi! Is geoloqi up an running? All my requsts returns empty data?
13:17 <Fredskronk> GPS is updating and can see it on the geoloqi site but nothing via api calls.
13:18 <patricka_> Fredskronk: aaronpk can help you
13:18 <Wraithan> aaronpk, ^
13:19 <aaronpk> hi ther
13:20 <Fredskronk> Hi,
13:21 <Fredskronk> aaronpk: Any info?
13:21 <aaronpk> what are you trying to retrieve via the API?
13:21 <aaronpk> there aren't any problems as far as I'm aware
13:22 <Fredskronk> I have a websocket stream that sudenly stopped updating and I get no data on a $geoloqi->get('location/last')
13:22 <Fredskronk> in PHP
13:23 <aaronpk> let me look into the websocket stuff real quick
13:23 <aaronpk> you should definitely see something with location/last in PHP tho
13:23 <aaronpk> do you get an empty array as a response, or an error message?
13:23 <Loqi> definitely
13:24 <Fredskronk> The array I create is empty and when i do a print_r($result) I get nothing. No object, no error just nothing :(
13:25 <aaronpk> is it possible that PHP is hiding the error because of the error reporting level or display_errors=Off?
13:26 <Fredskronk> Could be. Using it inside Drupal and it can be that Drupal hides errors. Will see if I can get error reporting on.
13:29 <starbuckt> Fredskronk: you might try making a simple request using Curl and see if that works (from the command-line not PHP).
13:29 <starbuckt> Just as a sanity-check.
13:30 <Fredskronk> No errors reportet. It was working a few hours ago.
13:30 <Fredskronk> Ok. Will try to do that. Not to friendly with curl but I'll try it. Hold on
13:31 <aaronpk> there's some examples here: http://developers.geoloqi.com/client-libraries/cURL
13:32 <Fredskronk> thanks
13:34 <Fredskronk> Got that working. My profile data shows up. Sadly this is run from anothger server as it's the one I have shell access to. (that one will be production when it goes live though)
13:35 patrickarlt joined #geoloqi
13:36 <Fredskronk> Curl is working on my dev server though. It gets data from another api I use (bing)
13:39 <Fredskronk> Streaming works again it seems. Walkt to my window and held out the phone and the screen updated (tried that a few times the last hour or so). No result in PHP though.
13:40 <Fredskronk> My code can be at fault ofcourse. Don't see what though since it worked earlier.
13:44 <aaronpk> yea strange, I'd suggest trying to find the error that PHP is reporting
13:44 <aaronpk> my guess is it's getting an error and hiding it, since you don't see any data in the response
13:45 <Fredskronk> PHP is not reporting any errors it seems. Have lines telling it to show all errors.
13:47 <aaronpk> is it possible the PHP code is using a different account?
13:48 <Fredskronk> I tried the demo code with my token and no response at all:
13:48 <Fredskronk> Will try another server. Just a moment.
13:56 <Fredskronk> Can't try another server it seems. Curl is working on the dev server. I know that since I get data from other apis via curl. As you can see from link abowe I get no data via the PHP library.
13:57 <Fredskronk> And no error. ini_set('display_errors', 1)
13:57 <Fredskronk> is set
13:58 <aaronpk> hmm, sometimes the server doesn't allow display_errors to be set in the code, do you know if you can see any other errors?
13:59 <aaronpk> i'll give you some sample code to try
14:04 patrickarlt joined #geoloqi
14:06 <aaronpk> Fredskronk: can you put this on the server and fill in your access token? https://gist.github.com/8524a63b266293d35bb8
14:07 <Fredskronk> Sure. Will do.
14:07 <Fredskronk> Checked with servecie provider btw. Server runs all right.
14:11 <Fredskronk> Error Message: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
14:12 <Fredskronk> How can I accept your certificate? Has it changed the last few hours?
14:12 <aaronpk> ah, that was my suspicion
14:12 <aaronpk> yes, we replaced the certificate a little less than 4 hours ago
14:13 <Fredskronk> Ah. IC. That's it then :) Thir is some code in curl that I can use to just accept all certs isn't it? Or do you have a new php library i shall download?
14:14 <aaronpk> No, don't use the "no ssl check" option, that's not safe.
14:14 <aaronpk> you shouldn't need to download a new library. I'm actually a little unsure why it isn't able to find the new certificate.
14:14 <Loqi> definitely
14:15 <aaronpk> I don't know what it uses to cache certs, but you could try searching for a way to clear php's ssl cert cache
14:15 <Fredskronk> Just a thought. When I got into the forums to check if someone had written about this I hade to accept an untrusted certificate. Connected to this?
14:16 <aaronpk> yes, that's been updated now too
14:16 <aaronpk> the certificate expired today, so we had to go update it with a new one everywhere
14:17 <Fredskronk> Ah. I see. They usaly have to be updated once in a while.
14:17 <Fredskronk> Will chekc with my provider.
14:24 <Fredskronk> ISP will clear the cash. Will come back if still problems. Thanks a million for all the help!
14:24 <aaronpk> great!
14:32 <Loqi> http://twitter.com/fredskronk :: @patrickarlt @geoloqi @geoloqi_status Ah. It seems my server won't accept your new certificate. Asked my service provider to flush cache.
15:33 Cameron joined #geoloqi
15:34 <Cameron> When I try to use the Geoloqi API Console to delete a trigger, it says access denied... can someone help?
15:35 <aaronpk> sure
15:35 <aaronpk> Cameron: you need to replace :id with the trigger ID you're trying to delete
15:36 <Cameron> I have. Same response.
15:37 <aaronpk> also you need to remove the ":", that's just a placeholder
15:38 <Cameron> One moment.
15:38 <Cameron> Still no change. How would I do this from the command line rather than the API Console?
15:38 <Cameron> Using curl.
15:41 <Cameron> Nevermind, solved my own problem. Had to include the OAuth authentication in the header of the curl post, not as a parameter. Sorry to bother.
16:12 Fredskronk joined #geoloqi
16:12 <Fredskronk> Hello again,
16:13 <Fredskronk> It seems that the team at my provider can't fix the problem at the moment. I have gotten som code to disable the check of the cert. Is it posible to fork your library to insert this?
16:13 <Fredskronk> curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, FALSE);
16:16 <Fredskronk> Like after line 52 in the geloqi.php file? Would it break?
16:23 <Fredskronk> Din't break. Will go for this for now. Thank you all for your help!
16:31 rknLA joined #geoloqi
17:36 patrickarlt joined #geoloqi
18:30 patrickarlt joined #geoloqi
19:12 jfrisby_ joined #geoloqi
19:35 patrickarlt joined #geoloqi
20:44 <Loqi> http://twitter.com/caseorganic :: @seanrconnell @li3n3 @kenkeiter Wearable computing hackathon date set! http://t.co/lYxf2o2i Jul 28 at @geoloqi hq! #hud #wearables
20:46 <Loqi> http://twitter.com/caseorganic :: @spincamapp @aaronpk @kyledrake @pmark @dmolnar Wearable computing hackathon date set! http://t.co/lYxf2o2i Jul 28 @geoloqi hq! #wearables
20:46 <Loqi> http://twitter.com/li3n3 :: @caseorganic @seanrconnell @kenkeiter @geoloqi Yessssss. That day became crazybusy for me, but I'll be there for a bit! Maybe lots of bits!
21:06 patrickarlt joined #geoloqi
23:35 starbuckt joined #geoloqi