00:06 <@LaurenPDodge> I love when he sends tracking links so I know when he'll be home for a skype date. #Geoloqi rocks. http://t.co/S1lBEB6g
01:05 rknLA joined #geoloqi
09:17 patrickarlt joined #geoloqi
09:36 patrickarlt joined #geoloqi
10:07 patrickarlt joined #geoloqi
11:08 caseorganic joined #geoloqi
11:34 mrgold_laptop- joined #geoloqi
11:36 caseorganic joined #geoloqi
11:48 <@icecreamman> hope this is somehow good for @geoloqi RT “@TechCrunch: Facebook Buys Location-Based Discovery App Glancee http://t.co/8VzKBl1t
12:04 kyledrake joined #geoloqi
12:18 patrickarlt joined #geoloqi
12:21 mxbc joined #geoloqi
12:23 <mxbc> Hi
12:26 <mxbc> question: How would one create an anonymous user with 'user/create_anon'. I have been trying with geoloqi_admin.post 'user/create_anon' and I get an error, Geoloqi::ApiError: invalid_client_credentials (400).
12:27 <mxbc> geoloqi_admin being a session instantiated with the following Geoloqi::Session.new :config => {:client_id => APP_CONFIG['geoloqi_client_id'], :client_secret => APP_CONFIG['geoloqi_client_secret']}
12:39 <aaronpk> mxbc: let me send you a code sample
12:41 <kyledrake> Hello!
12:42 <kyledrake> mxbc That looks right for instantiation. Let me check what we're using for that method call
12:42 <kyledrake> err, api call rather
12:42 <mxbc> right!
12:44 <kyledrake> Try adding adding the client_id and client_secret to the post params and see if that fixes it for you.
12:45 <mxbc> All right, let me try
12:46 <kyledrake> Also, you could "monkey patch" Session to do this, which I believe will also work: http://pastie.org/private/opbllxvekhbpraqgaqh0ma
12:47 <kyledrake> There's a twinge of oddness in the app-level command stuff, just because when we implemented it, the oauth2 stuff was still up in the air about how it would be implemented IIRC
12:47 <kyledrake> I will definitely make a note of this in the docs right now
12:47 <mxbc> I see, that fixed it
12:48 <mxbc> I got confused because I had already set them when instantiating my session
12:49 <kyledrake> Yeah, that is odd, I concur. I wonder if there's an elegant way to solve that via the ruby code..
12:50 <kyledrake> aha, my colleague has informed me that user/* all use this. Very easy to solve! I will do that now.
12:50 <mxbc> :)
12:52 <mxbc> this should also be reflected in the docs
12:53 <mxbc> I could not quite get my head around it, but now as I'm reading it, the doc makes sense
12:53 <kyledrake> Good point, thanks for the suggestion! Which doc are you reading for this?
12:54 <mxbc> btw awesome support
12:55 patricka_ joined #geoloqi
12:55 <kyledrake> Thanks! Yeah I've been working on the docs over the last few days so this fits really well
12:57 <mxbc> THe doc is great, really just got confused on how to instantiate the session vs. passing in the client_id/client_secret as post params.
13:01 caseorganic joined #geoloqi
13:07 <kyledrake> back in a bit, getting lunch
13:07 <kyledrake> (I'm starving..)
13:08 <mxbc> sure no prob
13:35 caseorganic joined #geoloqi
13:53 rknLA joined #geoloqi
14:36 starbuckt joined #geoloqi
14:42 <mxbc> All right, i'm having another issue here, group_response = geoloqi_admin.post 'group/create', :visibility => 'open', :publish_access => 'open'
14:43 <mxbc> and getting this error, missing_user - No user was specified. Request a specific user by setting user_id or username in the query string. (400)
14:44 <mxbc> and when I add a user_id to the request, missing_user - No user was specified in the request, and anonymous access to this method is not allowed. (403)
14:57 <mxbc> seems I can only see my request get through if I put in my client_id and client_secret as post params too
15:06 <starbuckt> mxbc, I believe that error is telling you that you haven't provided an Authentication header with your request.
15:06 <starbuckt> It's not the most specific error
15:07 <starbuckt> If you set the header: "Authentication: OAuth your_access_token" it should work
15:09 <mxbc> Ok, let me try, I thought this was handled by the session object.
15:21 <mxbc> my bad, my session object was not created properly!
15:21 <mxbc> thanks again
15:32 caseorganic joined #geoloqi
16:14 rknLA joined #geoloqi
16:16 rknLA_ joined #geoloqi
16:31 mrgold_laptop- joined #geoloqi
17:02 <@rubygems> geoloqi (0.9.41): http://t.co/Ln8rFwZi Powerful, flexible, lightweight, thread-safe interface to the Geoloqi Platform API
17:02 <kyledrake> mxbc: I just pushed an updated version of the ruby gem that provides an app_get and app_post method call, which sends the app credentials with the request in the headers. Hopefully this will make it easier to make these requests!
17:03 <kyledrake> I flirted with the idea of dropping in a route detection and just having it automatically throw it in, but there's some edge case security concerns.. such as if you were requesting user/list/SOME_OTHER_USER.
17:04 <kyledrake> Safer to explicitly requested escalated privileges I think :)
17:04 <mxbc> makes sense!
17:04 <mxbc> I'll pull it right away
17:11 <mxbc> Do you think that a gem that wraps calls to the api would work as well? Say I want to create an anon_user i'd simply call geoloqi.create_anon_user?
17:11 <mxbc> might be too hard to maintain though
17:12 <mxbc> and I've never built an api so I don't know eh ;P
17:13 <kyledrake> mxbc: I'm very interested in building a concrete version of our ruby adapter, which has a more structured interface
17:13 <kyledrake> I will likely implement this at some point!
17:13 <mxbc> Great!
17:14 <mxbc> I' looking forward to it
17:14 <kyledrake> I followed you on Github so I'll remember to send you a msg when I have something put together
17:14 <kyledrake> Demand definitely ups the priority on it :)
17:25 caseorganic joined #geoloqi
17:46 <mxbc> Haha thanks!
18:00 <@rubygems> geoloqi (0.9.43): http://t.co/Ln8rFwZi Powerful, flexible, lightweight, thread-safe interface to the Geoloqi Platform API
18:01 <kyledrake> mxbc you might want to update to 0.9.43.. faraday yanked out rack on me, so I had to add it as a dep.
18:01 <mxbc> haha no worries
18:03 <mxbc> I had not tested yet
18:03 <mxbc> Went to get dinner
18:38 <mxbc> kyledrake: Ok, now, if I use this, response = geoloqi_admin.app_post 'user/create_anon' i'm getting this error, client_id and client_secret are required to make application requests
18:48 <kyledrake> ah crud I think I know what that is. One moment
18:49 <kyledrake> What are you initializing the session object with?
18:50 <kyledrake> I changed it to access @config instead of config, which should be the exact same thing *scratching head&
19:13 <mxbc> Geoloqi::Session.new :client_id => APP_CONFIG['geoloqi_client_id'], :client_secret => APP_CONFIG['geoloqi_client_secret']
19:13 <mxbc> here it is
19:14 <mxbc> exact same thing as before
19:16 <kyledrake> Aha! Try this: Geoloqi::Session.new :config => {:client_id => APP_CONFIG['geoloqi_client_id'], :client_secret => APP_CONFIG['geoloqi_client_secret']}
19:16 <kyledrake> I need to document that better
19:16 <kyledrake> Actually, I should just make it so it works the way you provided it.. that makes total sense
19:17 <mxbc> Haha damn it!
19:18 <mxbc> just works.
19:18 <mxbc> my bad, i can't read
19:20 <mxbc> it was exactly *NOT* the same thing as before
19:20 <mxbc> haha
20:35 <kyledrake> No, I think you're right actually! That's a better way to do it
20:35 <kyledrake> I'll add something for that in the near future
21:01 <mxbc> all right!
21:01 <mxbc> i'm out its a bit late here
21:01 <mxbc> ta;l to you later
21:02 <mxbc> talk*
21:42 <@ginnycase> Heading out! Track me on Geoloqi! http://t.co/2E2Am850
21:51 caseorganic joined #geoloqi
23:23 patrickarlt joined #geoloqi