iOS SDK Getting Started linker error
  • I can run the sample app fine, and all the steps from Getting Started build fine until adding the first line of geoloqi code to the didFinishLaunchingWithOptions method:
    [LQSession setAPIKey:@"Your Client ID" secret:@"Your Client Secret"];
    It raises a linker error:
    Undefined symbols for architecture armv7:  "_OBJC_CLASS_$_JSONDecoder", referenced from:      objc-class-ref in libGeoloqi-Debug.a(LQSDKUtils.o)ld: symbol(s) not found for architecture armv7clang: error: linker command failed with exit code 1 (use -v to see invocation)

    What did I miss? I'm running Xcode 4.3.2 with deployment target iPhone 5.1. Thanks. -Mic
  • 3 Comments sorted by
  • I'm not the iOS developer, but I believe you need to include JSONKit in your project before building. This link might be helpful:

    https://community.geoloqi.com/discussion/comment/119#Comment_119
  • You're right. That was fast! I just needed to do these two things from that comment:
    2) copy JSON files to your project (Same two files as in the demo app: JSONKit.h and .m)
    5) under build phases and compile sources for JSONKit.m and add the following compiler flag: -fno-objc-arc

    Thank you. Solved!
  • Great! Glad I could help.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion