Device cannot receive push notification
  • Here are the basic steps that we are doing:

    1. Init geoloqi
    2. Register device for push notification service
    3. Create trigger using trigger/create (without specifying places or layer) but geoloqi automatically generates a places_id
    4. Run trigger using trigger/run/:id where :id is the generated trigger_id from create api call
    5. Close app and wait for device to get the notification but no notification arrives.

    Based on console debugging tool on geoloqi, everything seems to be running well from steps 1-4 and no error appears but we are confused why notification won't arrive on our device.

    We also tried calling message/send api that returned response that looks to be right but device didn't receive the message.

    A little clarification would definitely help here because we not sure if we are properly using geoloqi or not.


  • 8 Comments sorted by
  • Are you trying to get push notifications working on an Apple or an Android device?
  • Sorry, forgot to include that I'm trying to get notifications to work on Apple device.

  • It looks like we're getting SSL errors when trying to connect to Apple using your certificate. Can you verify you uploaded the correct certificates for development and production mode? 
  • I cannot tell if certificates are correct but we basically re generated the certificates from Apple Developer about an hour ago and again re-generated and uploaded it about 1 minute ago.

    This applies to both development and production certificates.

    We will run more tests on certificate that we uploaded using Urban Airship and will let you know probably next week but this was previously working before we decided to try and implement Geoloqi.

  • Hello Aaron,

    We can confirm that both production and development push certificates are working properly. We are getting notifications when sending it from Urban Airship.

    We were able to receive a notification after calling trigger/run/:id but only when using the development build (app installed by connecting device to mac and install) not when using AdHoc build (app installed via TestFlight)

    One performance issue we noticed is notification arrived 1 hour after invoking trigger/run/:id and it might be a problem for us if notifications do not arrive less than 1 minute after user enters certain region/area

  • Hello,

    I have been working on our push notifications over the last few days, which may have caused a temporary error with new certificates. Messages are usually sent within a few seconds, so what you are seeing is very unusual behavior.

    I have just pushed up some new code that deals with some unexpected Apple bugs, could you try sending a message again using the message/send api call?

    Apologies for the inconvenience, this update was prompted by a change in how Apple was using their protocol. If it's still giving you trouble, send me an email at and I will work with you to get this sorted out. Thanks!
  • Hello,

    We tried creating a trigger and calling trigger/run/:id twice and after 1-2 hours of waiting, notifications haven't arrived yet.

    We are using TestFlight AdHoc release so I think it was suppose to be using production push certificate. We also tested and push notification using production certificate are working via Urban Airship.

    Will connect with you via email probably tomorrow.


  • I have confirmed just now that there was an issue with development push notifications. I have corrected this problem just now, and development push notifications should be working again. This did not affect live push notifications.

    Again, I wanted to stress that this is not a frequent occurrence. This is a recent upgrade to our APNS service that will improve the reliability of our push notifications, and I don't expect this problem to happen again. I will integrate testing to prevent this problem from happening again in the future.

    If you are still having problems, please feel free to contact me and I will get back to you ASAP.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion