crashes leaving GPS function running
  • My Geoloqi ver 20120223 running on a 3Gs iphone crashed but the GPS functionality is still running making the phone very hot and killing the battery. Tried restarting then exiting Geoloqi as well as restarting the phone but the GPS functionality is still going. I exited all programs and restarted the phone again and still no luck. The GPS icon is still showing, the phone is getting really hot and the battery is running down extremely quickly. PLEASE help ASAP
  • 4 Comments sorted by
  • George,

    I'm sorry to hear about your issues with the app. Before I get in to the details, first allow me to point out that at any point you can prevent Geoloqi from accessing your location by going to the iPhone's "Settings" app and revoking location privileges for Geoloqi.

    Now, for the details. When the app is in "battery-safe" mode, you will see the location icon in the top bar, but that doesn't necessarily mean the GPS is on. The iPhone has the ability to use background location without using GPS by watching for changes in cell phone towers, etc.

    We will make sure to do some more tests with an iPhone 3GS (most of our recent tests are on the iPhone 4 and 4S) and will look in to this issue. Thanks for pointing this out to us!

  • Thanks for your quick response. I was really surprised to link up with anyone over the weekend. 

    I will try changing the location services in the setting as you suggest. Not sure though why the location service icon should be showing though if there are no programs running. My biggest concern is that the battery is running down very quickly, and the phone is quite hot. 

    I will let you know if I make any progress.
  • iOS 4 introduced the capability for iPhone apps to be registered for location updates even when they are not running.This doesn't necessarily mean the GPS itself is on, because the phone has the capability to receive location updates via wifi or cell tower changes.

  • Thank you for the lead - I was successful in turning off the location services for the program - the icon disappeared from the menu bar. 

    Turning the location services back on for Geoloqi and the icon showed up in the menu bar even though the program is not running.

    I turned the phone off and on and the icon still appeared in the bar as soon as I allowed Geoloqi access to location services - again the program is not running. 

    I apologize that I seem to be creating a problem for you with this. Is there any information from the phone that I can provide you that would be helpful.

    FYI - the crash happened twice - I think I inadvertently "pulled down" the summary screen (not sure what this is really called) and the program crashed - I allowed the phone to send the information when the program restarted - hopefully that will help with the trouble shooting. 

    feel free to contact me at 636-686-0005 if I can provide any information that will be helpful for you in trouble shooting the issue.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion