Javascript Library not working?
  • Tried the simple examples for javascript, but it doesn't get past the following line loading the geoloqi library ("t is null'). All other resulting calls result in a "geoloqi is null" error (which makes sense since the library didn't load).

    <script type="text/javascript" src=""></script>

    What am I doing wrong?
  • 2 Comments sorted by
  • I am getting the same error trying to load in both firefox and chrome, where the error reads "Uncaught TypeError: Cannot read property '2' of null" .   The firefox error "t is null" is referring to the same variable , show below.

    In chrome dev tools when viewing the minified js using "pretty print" , the error shows up around line 131 : 

    function B(e) {
    var t = e.toLowerCase().match(f), n = t[2], r = t[3], i = t[4] || "";
    imageUncaught TypeError: Cannot read property '2' of null
    if (n == "http:" && i == ":80" || n == "https:" && i == ":443")
    i = "";
    return n + "//" + r + i


    After further inspection, this error is related to parsing the uri .
    It fails when the uri begins with file:/// (and likely other variants)
    It works with http(s?)://
  • Yup. That is exactly it. Thanks!!!!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion