Titanium Geoloqi Plugin - Place/Update does not work
  • All,

    I am using Appcelerator Titanium SDK 3.0 and Geoloqi plugin 1.2 for my app. I can see my Geoloqi place/info call, but when I try to make the place/update to change the radius, there is no call made and no error. I see no activity on the phone, no onSuccess or onFailure events triggered, no debug information either on the phone or on the Geoloqi debugger. I tried downgrading to Titanium SDK 2.1.4 with no success.

    function UpdatePlace(placeID, radius, latitude, longitude) {
        try {
            geoloqi.session.postRequest("place/update/" + placeID, {
                radius: radius,
                latitude: latitude,
                longitude: longitude
            }, {
                onSucess: function (data) {
                    alert('Alert update was successful!');
                onFailure: function (data) {
                    alert('There was a problem updating the area of your alert.')
        } catch (e) {

    Can we either get a fix to the plugin or can someone suggest a workaround to changing the radius of a place? 


  • 2 Comments sorted by
  • All,

    I tested this further using the Geoloqi API console. Regardless of which account I use (personal or application) when I enter my place/update/place_id call I get 403 access denied. It doesn't matter what parameters I use either. I have tried all combinations of radius, latitude, longitude and layer and I get nothing. 

    Anyone? Anyone?
  • All,

    This is resolved. It appears to work fine now that I figured out the issue on the Titanium side. There was an error that Titanium swallowed that should have been reported. 

    My apologies if you wasted time on this one...

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion