Still no message/broadcast
  • iOS 5.
    Appcelerator SDK. 2.1.2
    Geoloqi for Titanium 1.2

    Several weeks ago Aaron replied to one of my posts regarding successful debug messages but no message received. 

    Aaron:
    "It sounds like the problem is that there was never any location data collected for the users, so the system doesn't know where they are.
    Here is what you should do:
    • As your application account, create Layer A. You'll do this only one time. Make a note of the layer ID that is returned.
    • From your app, after your user is created, subscribe them to this layer. Also make sure you have requested push notification permission and configured the certificates appropriately.
    • In the app, make sure you activate the SDK by setting the profile to "rough". This will cause the SDK to start sending location data.
    • Now you can send a message to anybody subscribed to the layer by using the message/broadcast method, sending a latitude,longitude and radius boundary.
    The layer bounds are calculated based on any places that are on the layer. If you don't have any places, you'll see an empty bounds parameter. "

    1) I have created Layer A. I saved the layer ID "1PuM". 
    2) When I initialize Geoloqi using geoloqi.init, I get the user ID "hZp" back. I am not creating a user separately. I am using the user id returned when I initialize. I subscribe this user to the "1PuM" layer
    3) Certs are configured. I get the triggers, so I assume push notification permission has been set properly as well.
    4) Tracking Profile is set to REALTIME. I can see location updates in the debugger.
    5) I send the message to the "1PuM" layer using the parameters below. 

    Nothing gets to the phones.  I checked my latitude and longitude to make sure I didn't get them backwards when I send the message. I didn't. I use the same latitude and longitude as the trigger, which goes through. I thought perhaps the message was too long and Apple dropped it, but I don't think it is. I also thought perhaps the message doesn't get sent by Apple since I am creating a trigger immediately before, but when I try to send a message by itself (no other Geoloqi calls before or after) it still doesn't go through. 

    {
    "longitude": -79.92942810058594,
    "latitude": 40.42375183105469,
    "text": "Bob BigBoy has been reported missing as of Sun Oct 07 2012 11:49:58 GMT-0400 (EDT) near Windsor St, Pittsburgh, Allegheny County, Pennsylvania, 15217, United States of America",
    "layer_id": "1PuM",
    "radius": 500
    }

    {
    "result": "ok",
    "total": 2,
    "push": 2,
    "sms": 0
    }

    I am really close to finishing this app, but I need to get this message broadcast functionality working. Any and all help is greatly appreciated!

    Thanks,
    Bruce








Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!